WooCommerce: actualización controlada de plantillas y downgrade

WordPress Deluxe. Oferta comercial. Actualización plantillas WooCommerce

Un error frecuente en instalaciones que utilizan WooCommerce como motor de su tienda online, es actualizar la versión de WooCommerce sin hacerlo previamente con la del tema que están utilizando, por desconocimiento o por imposibilidad (temas personalizados). Este error puede ocasionar fallos graves de funcionamiento en la tienda online. El error se identifica porque el sistema lanza un aviso que urge a actualizar las copias de las plantillas de WooCommerce en la instalación.

Servicio frecuente

Actualización controlada de plantillas de WooCommerce
by WordPressDeluxe

Justificación

Actualizar una versión de WooCommerce directamente en nuestro “entorno real”, puede generar este tipo de avisos de problemas de compatibilidad, o incluso provocar graves fallos en nuestra tienda online.

El problema es fácil de detectar, ya que nuestro escritorio de WordPress nos avisa del error en cuestión:

SECURITY ALERT: Su tema (—-) contiene copias no actualizadas de algunos archivos de plantilla WooCommerce. Estos archivos pueden necesitar cambios para garantizar que son compatibles con la versión actual de WooCommerce.

En el caso más sencillo, este error se soluciona actualizando el tema en instalaciones que utilizan temas premium o estándar con un gran número de instalaciones y un desarrollador responsable al otro lado. Sin embargo, en otros casos, el problema se agraba cuando no es posible actualizar el tema debido bien, a que se trata de un tema personalizado sin actualizaciones posteriores, o bien cuando se han añadido un gran número de modificaciones en el mismo que hacen temer que su actualización provoque pérdida relevante de funcionalidad en nuestra instalación.

Solución

Existen dos posibles soluciones: un downgrade de WooCommerce (una “marcha atrás” volviendo a la versión de WooCommerce que funcionaba, o una actualización detallada del código de las plantillas del tema.

En el segundo caso, como el propio desarrollador de WooCommerce advierte:

If the themes are not updated, or if you modified templates or are using a child theme, you need to update the templates yourself.

Si los temas no están actualizados, o si se han modificado plantillas o utilizado un tema hijo, necesitarás actualizar las plantillas por ti mismo.

Esta actualización de plantillas es necesariamente una revisión de cada plantilla una a una, actualizándola a la versión disponible de WooCommerce e incluyendo después todas las modificaciones manuales que se hayan hecho en el tema, una a una. Para realizar este trabajo es fundamental conocer a fondo WooCommerce y disponer de un profundo conocimiento de la programación PHP.

En WordPressDeluxe tenemos notable experiencia en ambas soluciones, tanto realizando downgrades de WooCommerce sin riesgos ni pérdida de información de ventas, como llevando adelante actualizaciones detalladas en código de plantillas.

Si necesitas que te ayudemos en esta tarea, solicita gratis un presupuesto sin compromiso.

WordPressDeluxe, diseñadores y programadores expertos en WordPress
Sitios web desde cero, tiendas online, planes de mantenimiento, reparaciones y optimizaciones, SEO y traducción.
Cualquier tarea que necesites, si es sobre WordPress, te propondremos la mejor solución.