Contacta con nosotros
  • Español
  • English

Error al actualizar WooCommerce: actualización controlada de plantillas

WordPress Deluxe. Oferta comercial. Actualización plantillas WooCommerce

Un error frecuente en instalaciones que utilizan WooCommerce como motor de su tienda online, es actualizar la versión de WooCommerce sin hacerlo previamente con la del tema que están utilizando, por desconocimiento o por imposibilidad (temas personalizados). Este error puede ocasionar fallos graves de funcionamiento en la tienda online. El error se identifica porque el sistema lanza un aviso que urge a actualizar las copias de las plantillas de WooCommerce en la instalación.

Servicio frecuente

Actualización controlada de plantillas de WooCommerce
by WordPressDeluxe

Justificación

Normalmente, este error se soluciona de forma sencilla actualizando el tema en instalaciones que utilizan temas premium o estándar con un gran número de instalaciones y un desarrollador responsable al otro lado. Sin embargo, los problemas surgen cuando se ha utilizado un tema personalizado, y no existe posibilidad de solicitar al desarrollador su adaptación para que sea compatible con las nuevas versiones de WooCommerce.

SECURITY ALERT: Su tema (—-) contiene copias no actualizadas de algunos archivos de plantilla WooCommerce. Estos archivos pueden necesitar cambios para garantizar que son compatibles con la versión actual de WooCommerce.

El proceso de solución cuando se trata de un tema personalizado (no se puede solicitar una actualización del tema al desarrollador, que estuviera ya adaptada a la versión de WooCommerce), es necesariamente una revisión uno a uno de cada fichero, actualizándolo a la versión disponible de WooCommerce e incluyendo después todas las modificaciones manuales que se hayan hecho en el tema, una a una. Para realizar este trabajo es fundamental conocer a fondo WooCommerce y disponer de un profundo conocimiento de la codificación.

Como el propio desarrollador de WooCommerce advierte:

If the themes are not updated, or if you modified templates or are using a child theme, you need to update the templates yourself.

Si los temas no están actualizados, o si se han modificado plantillas o utilizado un tema hijo, necesitarás actualizar las plantillas por ti mismo.

¿Qué ofrecemos?

Un servicio de diagnóstico para identificar la magnitud del problema, de revisión detallada y actualización del código necesario.

Adicionalmente, con nuestros servicios disfrutaras de una serie de beneficios que, normalmente, solo están al alcance de empresas que disponen de un departamento de sistemas de información propio, tales como:

  • Un entorno de desarrollo de tu instalación WordPress, copia de tu instalación, sobre el que trabajaremos para evitar riesgos.
  • Tus plantillas WooCommerce actualizadas a la versión más reciente de WooCommerce.
  • Una guía técnica detallada del trabajo realizado por nuestros expertos.

Para nuevos Clientes, además, ofrecemos gratuitamente:

  • Un diagnóstico general de tu instalación a cargo de profesionales expertos.
  • La identificación de un conjunto de oportunidades de mejora y optimización a futuro.

Esfuerzo orientativo

Esfuerzo total estimado
20-50
minutos
cada plantilla
orientativamente

Vuelve a disfrutar de tu instalación WooCommerce con toda su potencia.
Actualización controlada de plantillas de WooCommerce

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies. ACEPTAR

Aviso de cookies